Tag Archives: OCULUS RIFT S

Oculus Rift-S setup nightmare – the lad who wanted to fly

So a few months ago i seen Amazon had a sale on the VR headset ive followed for years the Oculus Rift. It was cheaper than i had ever seen before so i ordered one.

Excitement for Flying in PC VR with Flight Simulator 2020:
I cant begin to describe how excited i was to connect it to my PC in order to play Microsoft Flight Simulator 2020, my entire reason for buying it. I had a PC capable of VR and Graphics card well up for the task.

Problems:
When you connect the Oculus to your PC it does a check to see if everything is ok. You need to plug 1 cable into a USB 3.0 port (no problem I thought, I have loads!  Then you plug the other cable into your Graphics card. The software checks to see if all is good.

The Test:
I spent days searching for the problem and hoping there was a simple fix. I read post after post but nothing. i tried everything i read;

    • reinstall Oculus software
    • reinstall USB drivers
    • Motherboard driver
    • Update BIOS/settings
    • chipset drivers

USB 3 Ports:
The motherboard i have has 4 USB 3 ports some of them 3.2 gen and above, shouldn’t be any problems!

The Fucking Red-Green Headset Sensor Check nightmare:
Those two green checkmarks you get are great until they go red and you pull the cable out and reinsert and you get it green or red. This plug in and out bullshit fucking killed my interest in the headset.

All is good! Above is the all good signal your Headset is good to go!

 

Sensor cant track headset:Stuff of nightmares

Researching the problem:
I knew or thought i did that somebody must know the reason for this because Oculus didnt. All the help they give is to disconnect the headset for 10 seconds and reconnect it.  The number of times i did that.

The solution:
There’s no way id have ever figured this out without reading a reddit post saying to buy a USB 3 self powered hub from amazon.  it sounds so simple, I cant even remember how or why i found the post i did but if i remember right the person said they had the same problem i was mentioning.

The solution came from a comment on the reddit; https://www.reddit.com/r/oculus/comments/f75f3y/oculus_rift_s_turns_off_mid_play_along_with_all/

 

Last chance saloon:
So i thought nothing else has worked and chanced ordering this from amazon and it worked!

The USB 3 Hub i ordered:
https://www.amazon.co.uk/gp/product/B08ZKSK6MB?ref=em_1p_0_ti&ref_=pe_4028881_605832111